<!DOCTYPE html>
<html lang="en">
  <head>
          <meta charset="utf-8">
      <meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=5.0">
      <meta http-equiv="X-UA-Compatible" content="ie=edge">

      <title>Elden Ring bosses and Critical Role soundtracks take centre stage in the Dicebreaker Podcast | Dicebreaker</title>

  <meta property="og:description" content="Episode 108 of the Dicebreaker Podcast sees Matt, Chase and Meehan chatting about all the latest in tabletop gaming.">
  <meta property="og:site_name" content="Dicebreaker">
  <meta property="og:title" content="Elden Ring bosses and Critical Role soundtracks take centre stage in the Dicebreaker Podcast">
  <meta property="og:type" content="article">
  <meta property="og:url" content="https://www.dicebreaker.com/topics/dicebreaker-podcast/video/dicebreaker-podcast-108">
  <meta property="og:image" content="https://assets.dicebreaker.com/podcast-thumbnail-108.jpg/BROK/thumbnail/1600x900/format/jpg/quality/80/podcast-thumbnail-108.jpg">
  <meta property="article:published_time" content="2022-06-27T13:45:46.639806+00:00">
  <meta property="article:tag" content="Roleplaying Game">
  <meta property="article:tag" content="Trading Card Game (TCG)">
  <meta property="article:tag" content="Dungeons &amp; Dragons 5E">
  <meta property="article:tag" content="Board Game">
  <meta property="article:tag" content="Patchwork">
  <meta property="article:tag" content="Magic: The Gathering">
  <meta property="article:tag" content="Dicebreaker Podcast">
  <meta property="article:tag" content="Warhammer 40,000: Ninth Edition">
  <meta property="article:tag" content="Downforce">
  <meta property="article:tag" content="Arcs: Collapse and Conflict in the Void">
  <meta property="article:tag" content="Digital Board Game">

  <meta name="description" content="Episode 108 of the Dicebreaker Podcast sees Matt, Chase and Meehan chatting about all the latest in tabletop gaming.">
  <meta name="twitter:card" content="summary_large_image">
  <meta name="twitter:description" content="Episode 108 of the Dicebreaker Podcast sees Matt, Chase and Meehan chatting about all the latest in tabletop gaming.">
  <meta name="twitter:title" content="Elden Ring bosses and Critical Role soundtracks take centre stage in the Dicebreaker Podcast">
  <meta name="twitter:image" content="https://assets.dicebreaker.com/podcast-thumbnail-108.jpg/BROK/thumbnail/1600x800/format/jpg/quality/80/podcast-thumbnail-108.jpg">
  <meta name="twitter:image:alt" content="Thumbnail for podcast episode 108">
  <meta name="twitter:creator" content="@joindicebreaker">
  <meta name="twitter:site" content="@joindicebreaker">
  <meta name="robots" content="max-image-preview:large">
<link rel="apple-touch-icon" sizes="180x180" href="/static/3e913f27e1a6034c76545f5eddd175dc/icon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/static/3e913f27e1a6034c76545f5eddd175dc/icon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/static/3e913f27e1a6034c76545f5eddd175dc/icon/favicon-16x16.png">
<link rel="manifest" href="/static/3e913f27e1a6034c76545f5eddd175dc/icon/site.webmanifest">
<link rel="mask-icon" href="/static/3e913f27e1a6034c76545f5eddd175dc/icon/safari-pinned-tab.svg" color="#f2506e">
<link rel="shortcut icon" href="/static/3e913f27e1a6034c76545f5eddd175dc/icon/favicon.ico">
<meta name="msapplication-TileColor" content="#00aba9">
<meta name="msapplication-config" content="/static/3e913f27e1a6034c76545f5eddd175dc/icon/browserconfig.xml">
<meta name="theme-color" content="#ffffff">
<script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "NewsArticle",
    "url": "https://www.dicebreaker.com/topics/dicebreaker-podcast/video/dicebreaker-podcast-108",
    "mainEntityOfPage": "https://www.dicebreaker.com/topics/dicebreaker-podcast/video/dicebreaker-podcast-108",
    "headline": "Elden Ring bosses and Critical Role soundtracks take centre stage in the Dicebreaker Podcast",
    "inLanguage": "en",
    "articleSection": "Video",
    "description": "Episode 108 of the Dicebreaker Podcast sees Matt, Chase and Meehan chatting about all the latest in tabletop gaming.",
    "datePublished": "2022-06-27T13:45:46.639806+00:00",
    "publisher": {
        "@type": "Organization",
        "name": "Dicebreaker",
        "url": "https://www.dicebreaker.com/",
        "logo": {
            "@type": "ImageObject",
            "url": "https://assets.dicebreaker.com/0275_dicebreaker-logo-small.png",
            "width": 360,
            "height": 60
        }
    },
    "image": [
        "https://assets.dicebreaker.com/podcast-thumbnail-108.jpg/BROK/thumbnail/1200x1200/quality/100/podcast-thumbnail-108.jpg",
        "https://assets.dicebreaker.com/podcast-thumbnail-108.jpg/BROK/thumbnail/1200x900/quality/100/podcast-thumbnail-108.jpg",
        "https://assets.dicebreaker.com/podcast-thumbnail-108.jpg/BROK/thumbnail/1600x900/quality/100/podcast-thumbnail-108.jpg"
    ],
    "author": {
        "@context": "https://schema.org",
        "@type": "Person",
        "name": "Alex Meehan",
        "jobTitle": "Staff Writer, Dicebreaker",
        "worksFor": {
            "@type": "Organization",
            "name": "Dicebreaker",
            "url": "https://www.dicebreaker.com"
        },
        "image": "https://assets.dicebreaker.com/1576511959.png",
        "description": "Alex\u2019s journey to Dicebreaker began with writing insightful video game coverage for outlets such as Kotaku, Waypoint and PC Gamer. Her unique approach to analysing pop culture and knack for witty storytelling finally secured her a forever home producing news, features and reviews with the Dicebreaker team. She\u2019s also obsessed with playing Vampire: The Masquerade, and won\u2019t stop talking about it.",
        "url": "https://www.dicebreaker.com/authors/alex-meehan"
    },
    "keywords": [
        "Roleplaying Game",
        "Trading Card Game (TCG)",
        "Dungeons & Dragons 5E",
        "Board Game",
        "Patchwork",
        "Magic: The Gathering",
        "Dicebreaker Podcast",
        "Warhammer 40,000: Ninth Edition",
        "Downforce",
        "Arcs: Collapse and Conflict in the Void",
        "Digital Board Game"
    ]
}
</script>



<script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "name": "Home",
            "item": "https://www.dicebreaker.com/"
        },
        {
            "@type": "ListItem",
            "position": 2,
            "name": "Videos",
            "item": "https://www.dicebreaker.com/archive/video"
        }
    ]
}
</script>

<script>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</script>
<script async src="https://0f73e92f-4074-4fe3-85d3-ed3fc969859e.edge.permutive.app/0f73e92f-4074-4fe3-85d3-ed3fc969859e-web.js"></script>  <script>
    window.dataLayer = window.dataLayer || [];
    function gtag() { dataLayer.push(arguments); }

    function _appendGoogleAnalytics(anonymous) {
        if (window.gtagDone) return;

        gtag('js', new Date());

        const options = {
    "dimension4": "0",
    "dimension5": "0",
    "dimension1": "video",
    "dimension2": "roleplaying-game,trading-card-game,dungeons-and-dragons-5e,board-game,patchwork,magic-the-gathering-game,dicebreaker-podcast,warhammer-40000-ninth-edition,downforce,arcs-collapse-and-conflict-in-the-void,digital-board-game",
    "dimension3": "Alex Meehan",
    "dimension7": "2022-06-27",
    "dimension8": "magic-the-gathering-game,arcs-collapse-and-conflict-in-the-void,patchwork,warhammer-40000-ninth-edition,dungeons-and-dragons-5e,downforce"
};

        options['link_attribution'] = true;

        if (anonymous) {
          options['client_storage'] = 'none';
          options['store_gac'] = false;
          options['anonymize_ip'] = true;


          options['dimension6'] = '1';
        } else {
          options['dimension6'] = '0';
        }

        gtag('config', 'UA-144850357-1', options);


        const gaScript = document.createElement('script');
        gaScript.type = 'text/javascript';
        gaScript.async = true;
        gaScript.src = 'https://www.googletagmanager.com/gtag/js?id=UA-144850357-1';

        document.getElementsByTagName('head')[0].appendChild(gaScript);
        window.gtagDone = true;

        window.dispatchEvent(new Event('BrockmanAnalyticsEnabled'));
    }

    function appendGoogleAnalytics() {
      _appendGoogleAnalytics(false);
    }

    function appendGoogleAnalyticsAnonymous() {
      _appendGoogleAnalytics(true);
    }

    window.addEventListener('BrockmanPerformanceCookiesAllowed', appendGoogleAnalytics);
    window.addEventListener('BrockmanPerformanceCookiesDisallowed', appendGoogleAnalyticsAnonymous);
  </script>
  <script>
      window.PARSELY = window.PARSELY || {
        autotrack: false,
        onReady: function() {
          PARSELY.updateDefaults({
            data: {
    "user": "unregistered"
}
          });
          PARSELY.beacon.trackPageView();
        }
      };

    function appendParsely() {
        if (window.parselyDone) return;
        (function(d) {
          var b = d.body;
          var e = d.createElement('script');
          e.id = 'parsely-cfg';
          e.src = '//cdn.parsely.com/keys/dicebreaker.com/p.js';
          b.appendChild(e);
        })(document);
        window.parselyDone = true;
    }

    window.addEventListener('BrockmanPerformanceCookiesAllowed', appendParsely);
  </script>

  <script>
    window.mainScriptsEvent = document.createEvent('CustomEvent');
    window.mainScriptsEvent.initCustomEvent('mainScripts');
  </script>
  <script defer src="/static/3e913f27e1a6034c76545f5eddd175dc/js/main.min.js" onload="window.dispatchEvent(window.mainScriptsEvent)"></script>

<script>
  window.addEventListener('mainScripts', function() {
    window.BrockmanLazyLoad = new BrockmanLazyLoad();
    window.BrockmanLazyLoad.run();
  });
</script>
<script>
  window.addEventListener('mainScripts', function() {
    window.BrockmanLightbox = new BrockmanLightbox({});
    window.BrockmanLightbox.run();
  });
</script>

  <script>
    window.commercialScriptsEvent = document.createEvent('CustomEvent');
    window.commercialScriptsEvent.initCustomEvent('commercialScripts');
  </script>
  <script defer src="/static/3e913f27e1a6034c76545f5eddd175dc/js/commercial.min.js" onload="window.dispatchEvent(window.commercialScriptsEvent)"></script>



  <link rel="preload" href="https://securepubads.g.doubleclick.net/tag/js/gpt.js" as="script">
  <link rel="preload" href="https://c.amazon-adsystem.com/aax2/apstag.js" as="script">

<script>
  function appendBrockmanAds() {
      if (window.brockmanAdsDone) return;

      const adConfig = {
          custom_variables: {
    "logged_in": "false",
    "source": "article",
    "version": "hd",
    "tags": [
        "video",
        "magic-the-gathering-game",
        "trading-card-game",
        "arcs-collapse-and-conflict-in-the-void",
        "patchwork",
        "roleplaying-game",
        "digital-board-game",
        "warhammer-40000-ninth-edition",
        "dicebreaker-podcast",
        "board-game",
        "dungeons-and-dragons-5e",
        "downforce"
    ],
    "games": [
        "magic-the-gathering-game",
        "arcs-collapse-and-conflict-in-the-void",
        "patchwork",
        "warhammer-40000-ninth-edition",
        "dungeons-and-dragons-5e",
        "downforce"
    ]
},
          device: 'hd',
          runUAM: false,
          runPrebid: false,
          biddingTimeout: 1400,
          prebidLib: '',
          prebidConfig: {},
          stickySidebar: false,
          stickyViewports: 3,
          advertHeader: 'Advertisement',
          countryCode: 'US',
          refreshAds: {
            enabled: false,
            maxRefreshes: 10,
            desktopRate: 30000,
            mobileRate: 30000,
            mobileStickyRate: 30000,
            teadsRate: 30000,
            refreshableAdvertIds: [  ],
          },
          videoPlaylist: false,
          videoPlaylistArticles: false,
          videoPlaylistTitle: '',
          videoPlaylistID: '',
          videoPlaylistGamesList: {},
            bbwPublication: 'dicebreaker',
            bbwAutoplay: 'dicebreaker_autoplay',
            articleType: 'video',
              articlePublishedDate: '2022-06-27 13:45:46.639806+00:00',
              inlineInto: '',
              insertInto: '.gn_sidebar',
              firstMobileAd: 'DICEB_MPU_MOB',
              dynamicAd: 'DICEB_Lazy_Load_HP_MPU',
              stickyAd: 'DICEB_STICKY_LB',
              apesterToken: '615c0dfe3abb86000dae2197',
              apesterDesktop: 'article .article_body_content',
              mobileInReadId: '',
              desktopInReadId: '',
          adRenderedCallback: (slotName, event) => {
              if (!event.isEmpty) return;
              const ad = document.getElementById(slotName);
              if (ad && ad.dataset.dfpCollapse == 'true')
                ad.parentNode.style.display = 'none';
          }
      }

        const cohorts = [];

      window.BrockmanAds = new BrockmanAds('.advert', adConfig, cohorts);
      window.BrockmanAds.init();
      window.brockmanAdsDone = true;
  }

  window.addEventListener('BrockmanTCFConsent', appendBrockmanAds);

</script>


<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: '2', c2: '8518622', cs_ucfr: '' });

  function appendComscore(cs_ucfr_value) {
    (self.COMSCORE && COMSCORE.beacon({ c1: "2", c2: "8518622", cs_ucfr: cs_ucfr_value }));
    if (window.comscoreDone) return;
    _comscore[0].cs_ucfr = cs_ucfr_value;
    const s = document.createElement("script");
    const el = document.getElementsByTagName("script")[0];
    s.type = 'text/javascript';
    s.async = true;
    s.src = 'https://sb.scorecardresearch.com/cs/8518622/beacon.js';
    el.parentNode.insertBefore(s, el);
    window.comscoreDone = true;
  }

  window.addEventListener('BrockmanTargetingCookiesDisallowed', () => appendComscore(0));
  window.addEventListener('BrockmanTargetingCookiesAllowed', () => appendComscore(1));
</script>


  <script>
    function appendSkimlinks() {
      if (window.skimlinksDone) return;
      const skimlinksScript = document.createElement('script');
      skimlinksScript.type = 'text/javascript';
      skimlinksScript.async = true;
      skimlinksScript.src = 'https://s.skimresources.com/js/87431X1608146.skimlinks.js';
      document.getElementsByTagName('head')[0].appendChild(skimlinksScript);
      window.skimlinksDone = true;
    }

    window.addEventListener('BrockmanTargetingCookiesAllowed', appendSkimlinks);
  </script>

  <script>
    function appendFacebookPixels() {
      if (window.facebookPixelsDone) return;
      !function(f,b,e,v,n,t,s)
      {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
      n.callMethod.apply(n,arguments):n.queue.push(arguments)};
      if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
      n.queue=[];t=b.createElement(e);t.async=!0;
      t.src=v;s=b.getElementsByTagName(e)[0];
      s.parentNode.insertBefore(t,s)}(window, document,'script',
      'https://connect.facebook.net/en_US/fbevents.js');

        fbq('init', '281147926378683');

      fbq('track', 'PageView');
      window.facebookPixelsDone = true;

      window.dispatchEvent(new Event('BrockmanFacebookPixelsEnabled'));
    }

    window.addEventListener('BrockmanTargetingCookiesAllowed', appendFacebookPixels);
  </script>



  <script>
    window.articleScriptsEvent = document.createEvent('CustomEvent');
    window.articleScriptsEvent.initCustomEvent('articleScripts');
  </script>
  <script defer src="/static/3e913f27e1a6034c76545f5eddd175dc/js/article.min.js" onload="window.dispatchEvent(window.articleScriptsEvent)"></script>

  <script>
    window.addEventListener('articleScripts', function() {
      window.BrockmanEdmonds = new BrockmanEdmonds({
        selector: '.edmonds-block',
        site: 'dicebreaker.com',
        edmonds_url: 'https://edmonds.gamer-network.net',
      });
      window.BrockmanEdmonds.run();
    });
  </script>



  <script defer src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="2790297a-4108-4f99-b492-27801f14b89c"></script>

<script>
  function enableElements() {
    const elements = document.querySelectorAll('iframe[data-src], script[data-src], img[data-src]');
    for (let i = 0; i < elements.length; i ++) {
      const element = elements[i];
      element.setAttribute('src', element.dataset.src);
    }
  }

  function showEmbedPlaceholders() {
    if (window.embedPlaceholdersDone) return;
    const elements = document.querySelectorAll('.embed_placeholder');
    for (let i = 0; i < elements.length; i ++) {
      const element = elements[i];
      element.style.display = '';
    }
    window.embedPlaceholdersDone = true;
  }

  function hidePerformanceEmbedPlaceholders() {
    hideEmbedPlaceholders('performance');
  }

  function hideFunctionalEmbedPlaceholders() {
    hideEmbedPlaceholders('functional');
  }

  function hideTargetingEmbedPlaceholders() {
    hideEmbedPlaceholders('targeting');
  }

  function hideEmbedPlaceholders(type) {
    const identifier = '.embed_placeholder' + (type ? '[data-type="' + type + '"]' : '');
    const elements = document.querySelectorAll(identifier);
    for (let i = 0; i < elements.length; i ++) {
      const element = elements[i];
      element.style.display = 'none';
    }
  }

  function performanceCookiesAllowed() {
    window.dispatchEvent(new Event('BrockmanPerformanceCookiesAllowed'));
    hidePerformanceEmbedPlaceholders();
  }

  function performanceCookiesDisallowed() {
    window.dispatchEvent(new Event('BrockmanPerformanceCookiesDisallowed'));
  }

  function functionalCookiesAllowed() {
    window.dispatchEvent(new Event('BrockmanFunctionalCookiesAllowed'));
    hideFunctionalEmbedPlaceholders();
  }

  function functionalCookiesDisallowed() {
    window.dispatchEvent(new Event('BrockmanFunctionalCookiesDisallowed'));
  }

  function targetingCookiesAllowed() {
    window.dispatchEvent(new Event('BrockmanTargetingCookiesAllowed'));
    enableElements();
    hideTargetingEmbedPlaceholders();
  }

  function targetingCookiesDisallowed() {
    window.dispatchEvent(new Event('BrockmanTargetingCookiesDisallowed'));
  }


    function OptanonWrapper() {
        window.BrockmanAllowedCookies = {
          performance: OptanonActiveGroups.match(/,2,/) !== null,
          functional: OptanonActiveGroups.match(/,3,/) !== null,
          targeting: OptanonActiveGroups.match(/,4,/) !== null,
        };

        showEmbedPlaceholders();

        window.BrockmanAllowedCookies.performance ?
          performanceCookiesAllowed() : performanceCookiesDisallowed();

        window.BrockmanAllowedCookies.functional ?
          functionalCookiesAllowed() : functionalCookiesDisallowed();

        window.BrockmanAllowedCookies.targeting ?
          targetingCookiesAllowed() : targetingCookiesDisallowed();

        if ('__tcfapi' in window) {
          __tcfapi('getTCData', 2, (tcData, success) => {
            if (success && tcData.purpose.consents[1]) {
              window.consentString = tcData.tcString;
              window.dispatchEvent(new Event('BrockmanTCFConsent'));
            } else {
              window.dispatchEvent(new Event('BrockmanTCFOptOut'));
            }
          });
        } else {
          window.dispatchEvent(new Event('BrockmanTCFOptOut'));
        }
    }
</script>
  <style>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</style>

        <link rel="canonical" href="https://www.dicebreaker.com/topics/dicebreaker-podcast/video/dicebreaker-podcast-108">

      <link rel="alternate" type="application/rss+xml" href="/feed">




    <script>
      function appendApester() {
        if (window.apesterDone) return;

        const apesterScript = document.createElement('script');
        apesterScript.async = true;
        apesterScript.src = '//static.apester.com/js/sdk/v2.0/apester-javascript-sdk.min.js';
        document.getElementsByTagName('head')[0].appendChild(apesterScript);

        window.apesterDone = true;
      }

      window.addEventListener('BrockmanTargetingCookiesAllowed', appendApester);
    </script>
  </head>
  <body
      data-version="hd"
      data-page="article"
      data-ads="true"
      data-affiliates="true"
      data-menu="false"
  >
    <div id="app_wrapper">
        <header class="app_header">


  <nav class="nav_trending">
            <span class="label">Trending</span>


        <ul>
                  <li>
                    <a
                      href="https://www.dicebreaker.com/games/pokemon-trading-card-game/best-games/rare-pokemon-cards"
                      data-active="false"
                      
                    >
                        Rare Pokémon cards
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.dicebreaker.com/topics/board-games/best-games/best-board-games-2022"
                      data-active="false"
                      
                    >
                        Best board games
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.dicebreaker.com/categories/board-game/best-games/best-board-games-for-couples"
                      data-active="false"
                      
                    >
                        Best board games for couples
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.dicebreaker.com/games/yu-gi-oh-tcg/how-to/yu-gi-oh-banlist-forbidden-limited"
                      data-active="false"
                      
                    >
                        Yu-Gi-Oh! Banlist
                    </a>
                  </li>
        </ul>
  </nav>
  <nav class="nav_main">
  <div class="logo_wrapper">
    

<a
  href="/"
  class="logo"
  
>
    <img src="https://assets.dicebreaker.com/0275_dicebreaker-logo.svg" alt="Dicebreaker logo" loading="eager">
</a>
    <span class="strapline">Board games. For everyone.</span>
  </div>



  <nav class="nav_primary">
        

        <ul>
                  <li>
                    <a
                      href="/archive/news"
                      data-active="false"
                      
                    >
                        News
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/review"
                      data-active="false"
                      
                    >
                        Reviews
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/features"
                      data-active="false"
                      
                    >
                        Features
                    </a>
                  </li>
                  <li>
                    <a
                      href="/videos"
                      data-active="false"
                      
                    >
                        Videos
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/deal"
                      data-active="false"
                      
                    >
                        Deals
                    </a>
                  </li>
                  <li>
                    <a
                      href="/best-games"
                      data-active="false"
                      
                    >
                        Best Games
                    </a>
                  </li>
                  <li>
                    <a
                      href="/how-to-play"
                      data-active="false"
                      
                    >
                        How to Play
                    </a>
                  </li>
                  <li>
                    <a
                      href="/categories/board-game"
                      data-active="false"
                      
                    >
                        Board Games
                    </a>
                  </li>
                  <li>
                    <a
                      href="/categories/roleplaying-game"
                      data-active="false"
                      
                    >
                        Roleplaying
                    </a>
                  </li>
                  <li>
                    <a
                      href="/events"
                      data-active="false"
                      
                    >
                        Events
                    </a>
                  </li>
        </ul>
  </nav>



  <nav class="nav_secondary">
        

        <ul>
                  <li>
                    <a
                      href="/games/dungeons-and-dragons-5e"
                      data-active="false"
                      
                    >
                        Dungeons &amp; Dragons 5E
                    </a>
                  </li>
                  <li>
                    <a
                      href="/games/magic-the-gathering-game"
                      data-active="false"
                      
                    >
                        Magic: The Gathering
                    </a>
                  </li>
                  <li>
                    <a
                      href="/topics/kickstarter"
                      data-active="false"
                      
                    >
                        Kickstarter
                    </a>
                  </li>
                  <li>
                    <a
                      href="/topics/dicebreaker-podcast"
                      data-active="false"
                      
                    >
                        Dicebreaker Podcast
                    </a>
                  </li>
                  <li>
                    <a
                      href="/games"
                      data-active="false"
                      
                    >
                        Latest Games
                    </a>
                  </li>
        </ul>
  </nav>


      <div class="actions">
  <form class="search_box" action="/search">
    <input type="text" name="q" aria-label="Search" placeholder="Search">
  </form>

    <div class="user_profile signed_out">
    <div class="button_group">
        <a class="button small login" href="/community/auth/start?next=/topics/dicebreaker-podcast/video/dicebreaker-podcast-108" rel="nofollow">Sign in / Create account</a>
    </div>
  </div>

    <div class="visit_store_wrapper">
  <a
    href="https://store.reedpop.com/collections/Dicebreaker"
    target="_blank"
    rel="noopener"
    class="button small"
  >
    Visit our store
  </a>
    </div>
      </div>
  </nav>
        </header>

        <main id="page_wrapper">
  <div class="advert_container leaderboard_container">
    <div class="advert leaderboard"
      data-dfp-id="DICEB_LB_1"
      data-dfp-sizes="300x250, 320x50, 728x90, 960x160, 960x250, 970x250, 1260x110, 1260x160, 1260x200, 1260x250"
      data-dfp-targeting="site=dicebreaker"
      id="DICEB_LB_1_1"
    ></div>
  </div>

              <div id="content">
  <div id="content_above">
        <div class="page_content">


<div class="disclaimer">
If you click on a link and make a purchase we may receive a small commission.  <a href="/editorial-policy">Read our editorial policy</a>.
</div>
  <article
    class="article "
data-ads="true"
data-article-type="video"
data-paywalled="false"
data-premium="false"
data-type="article"
  >

<header class="article_header">
  <div class="breadcrumbs">


  <nav class="nav_breadcrumbs">
        

        <ul>
                  <li>
                    <a
                      href="/"
                      data-active="false"
                      
                    >
                        Home
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/video"
                      data-active="false"
                      
                    >
                        Videos
                    </a>
                  </li>
        </ul>
  </nav>
  </div>

    <div class="details">
          <h1 class="title">    Elden Ring bosses and Critical Role soundtracks take centre stage in the Dicebreaker&nbsp;Podcast
</h1>


        <span class="strapline">Alongside Magic: The Gathering and Arcs.</span>

    </div>

    <div class="metadata">

<div class="avatar">
  <img
    src="https://assets.dicebreaker.com/1576511959.png/BROK/thumbnail/70x70/quality/60/1576511959.png"
    srcset="https://assets.dicebreaker.com/1576511959.png/BROK/thumbnail/70x70/quality/60/1576511959.png 1x, https://assets.dicebreaker.com/1576511959.png/BROK/thumbnail/140x140/quality/60/1576511959.png 2x"
loading="lazy"    class="avatar_image"
    alt="Alex Meehan avatar"
width="70"height="70"  >
</div>
        <div class="author">
              <span class="article_type" data-slug="video">
                Video
              </span>

<span class="by">by</span> <span class="name">                  <a href="/authors/alex-meehan">Alex Meehan</a>
</span>                <span class="job_title">
                    Staff Writer, Dicebreaker
                </span>
        </div>


        <div class="published_at">
Published on <time datetime="2022-06-27 13:45:46.639806+00:00">June 27, 2022</time>        </div>

    </div>





<div class="headline_asset">

  <div class="video_wrapper">
<iframe
    src="https://www.youtube-nocookie.com/embed/QbLEBLGe5BM?autoplay=0"
  loading="lazy"
  data-src="https://www.youtube.com/embed/QbLEBLGe5BM?autoplay=0"
  frameborder="0"
  allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"
  allowfullscreen
>
</iframe>  </div>
</div>
</header>  <div class="article_body">


  <aside class="about_game">
    <span class="heading">
      About <a href="/games/dungeons-and-dragons-5e">Dungeons &amp; Dragons 5E</a>
    </span>

    <p class="released">
      Released: <span>2014</span>
    </p>



    <p class="rules_complexity">
      Rules complexity: <span>Medium</span>
    </p>

    <p class="strategic_depth">
      Strategic depth: <span>Medium</span>
    </p>
    <p class="publishers">
        Publisher:
        <span>Wizards of the Coast</span>    </p>
  </aside>
          <div class="article_body_content">



            <p>Episode 108 of the Dicebreaker Podcast sees Matt, Chase and Meehan chatting about all the latest in tabletop gaming.</p>
<p>The trio take some time to share their thoughts on the upcoming board game from Root creator Cole Wehrle, Arcs, which they played together through Tabletop Simulator the other week.</p>
<p>Turns out Matt Jarvis has been playing a good deal of <a href="https://www.dicebreaker.com/categories/trading-card-game/best-games/best-trading-collectible-expandable-card-games">trading card game</a> Magic: The Gathering, trying out the Unsanctioned released &ndash; which is specifically designed for casual play &ndash; and giving the unofficial Pack Wars format a go. On top of that, Matt chats about his experiences with an online digital version of the classic game Mahjong, which happens to feature a cat girl mascot.</p>
<p>After this, Chase and Matt discuss their recent marathon of board games including the racing title Downforce, <a href="https://www.dicebreaker.com/categories/board-game/best-games/best-two-player-board-games-2022">two-player board game</a> Patchwork, Copenhagen, fishing board game Fleet and Tigris &amp; Euphrates. Chase also takes the time to mention a Warhammer miniatures game that he and his friends have been hacking.</p>
<p>Lastly, Meehan highlights the queer tabletop roleplaying game Thirsty Sword Lesbians, which she played with Wheels, Liv and Maddie in celebration of Pride Month and to raise money for the trans youth charity Mermaids.</p>
<p>In the news, the trio comment on the recently announced formation of a <a href="https://www.dicebreaker.com/topics/critical-role/news/critical-role-welcome-to-taldorei-soundtrack">Critical Role record label</a> and the studio&rsquo;s first release &ndash; a soundtrack inspired by Vox Machina, the first campaign of the actual play series. Another discussed news item was a <a href="https://www.dicebreaker.com/games/dungeons-and-dragons-5e/news/elden-ring-dnd-stat-blocks-5e">supplement for D&amp;D 5E designed by a fan of the video game Elden Ring</a>, which contains a collection of bosses inspired by several featured in the Fromsoft game.</p>
<p>Using this a jumping-off point, Matt, Meehan and Chase come up with their own ideas for video game bosses that could also make for great TRPG encounters &ndash; including bosses from the Metal Gear Solid series, Meta Gear Rising: Revengeance and Resident Evil 2: Remake.</p>
<iframe allow="autoplay; clipboard-write; encrypted-media; fullscreen; picture-in-picture" allowfullscreen data-src="https://open.spotify.com/embed/show/45mxfdjGUPY6dXYS8HWOnh?utm_source=generator" frameborder="0" height="232" width="100%"></iframe><span class="embed_placeholder" data-type="targeting" style="display: none;">
<span class="message">To see this content please enable targeting cookies.</span>
<button class="ot-sdk-show-settings" id="ot-sdk-btn">Manage cookie settings</button>
</span>
<p>The podcast is filmed live every Friday at 2PM BST, you can catch the latest episode then on the <a href="https://www.youtube.com/channel/UC0jMXccxfvnwXvTpngFwbNA">Dicebreaker YouTube channel</a>. Otherwise, you can listen to the newest episode on <a href="https://open.spotify.com/show/45mxfdjGUPY6dXYS8HWOnh">Spotify,</a> <a href="https://podcasts.apple.com/gb/podcast/dicebreaker-podcast/id1506228736">iTunes</a>, <a href="https://www.stitcher.com/podcast/dicebreaker-podcast">Stitcher</a> and <a href="https://podcasts.google.com/?feed=aHR0cHM6Ly9kaWNlYnJlYWtlci5saWJzeW4uY29tL3Jzcw&amp;ved=0CAAQ4aUDahcKEwigup37rIPpAhUAAAAAHQAAAAAQAQ&amp;hl=en-GB">Google Podcasts</a>. You can also add the podcast's <a href="https://dicebreaker.libsyn.com/rss">RSS feed</a> to your player of choice.</p>
<p>Do you have any questions or suggestions of TRPG video game bosses for the Dicebreaker Podcast? You can post them in this article&rsquo;s comment section or tweet us <a href="https://twitter.com/joindicebreaker"> @joindicebreaker</a> or email us at contact@dicebreaker.com</p>
<p><strong>Games (and other stuff) discussed </strong></p>
<ul>
<li>Arcs</li>
<li>Magic: The Gathering</li>
<li>Mahjong</li>
<li>Downforce</li>
<li>Patchwork</li>
<li>Copenhagen</li>
<li>Fleet</li>
<li>Tigris &amp; Euphrates</li>
<li>Dungeons &amp; Dragons 5E</li>
<li>Thirsty Sword Lesbians</li>
<li>Elden Ring</li>
<li>Metal Gear Solid 3: Snake Eater</li>
<li>Metal Gear Rising: Revengeance</li>
<li>Resident Evil 2: Remake</li>
<li>The Legend of Zelda: Twilight Princess</li>
<li>The Legend of Zelda: The Wind Waker</li>
</ul>

        </div>





  </div>
  </article>

<footer class="article_footer">
  <hr class="divider" />
  

  <div class="tagged_with">
      <h2 class="section_title small">Tagged With</h2>
    <ul>
        <li>
          <a href="/games/arcs-collapse-and-conflict-in-the-void">Arcs: Collapse and Conflict in the Void</a>
        </li>
        <li>
          <a href="/categories/board-game">Board Game</a>
        </li>
        <li>
          <a href="/topics/dicebreaker-podcast">Dicebreaker Podcast</a>
        </li>
        <li>
          <a href="/categories/digital-board-game">Digital Board Game</a>
        </li>
        <li>
          <a href="/games/downforce">Downforce</a>
        </li>
        <li>
          <a href="/games/dungeons-and-dragons-5e">Dungeons &amp; Dragons 5E</a>
        </li>
        <li>
          <a href="/games/magic-the-gathering-game">Magic: The Gathering</a>
        </li>
        <li>
          <a href="/games/patchwork">Patchwork</a>
        </li>
        <li>
          <a href="/categories/roleplaying-game">Roleplaying Game</a>
        </li>
        <li>
          <a href="/categories/trading-card-game">Trading Card Game (TCG)</a>
        </li>
        <li>
          <a href="/games/warhammer-40000-ninth-edition">Warhammer 40,000: Ninth Edition</a>
        </li>
    </ul>
  </div>

  <div class="author_bio compact">
      <h2 class="section_title small">About the Author</h2>





<article class="summary" data-type="persona">
    <a
      href="/authors/alex-meehan"
      class="link_overlay"
      title="Alex Meehan"
    ></a>

<div class="avatar">
  <img
    src="https://assets.dicebreaker.com/1576511959.png/BROK/thumbnail/70x70/quality/60/1576511959.png"
    srcset="https://assets.dicebreaker.com/1576511959.png/BROK/thumbnail/70x70/quality/60/1576511959.png 1x, https://assets.dicebreaker.com/1576511959.png/BROK/thumbnail/140x140/quality/60/1576511959.png 2x"
loading="lazy"    class="avatar_image"
    alt="Alex Meehan avatar"
width="70"height="70"  >
</div>
  <div class="details">
        <p class="name">
            <a href="/authors/alex-meehan">Alex Meehan</a>
        </p>

      <p class="job_title">
        Staff Writer, Dicebreaker
      </p>


        <p class="bio">
          Alex’s journey to Dicebreaker began with writing insightful video game coverage for outlets such as Kotaku, Waypoint and PC Gamer. Her unique approach to analysing pop culture and knack for witty storytelling finally secured her a forever home producing news, features and reviews with the Dicebreaker team. She’s also obsessed with playing Vampire: The Masquerade, and won’t stop talking about it.
        </p>
  </div>
</article>  </div>

  <div id="comments">
      <h2 class="section_title small">Comments</h2>

    <div class="container"></div>

    <noscript>
      <p class="alert error">
Please enable JavaScript to see comments.      </p>
    </noscript>

  <script>
    window.addEventListener('articleScripts', () => {
      window.BrockmanComments = new BrockmanComments({
          id: '/community/thread/omye8w',
          postCount: '0',
loadComments: true,          previewEndpoint: '/community/preview',
          loc: {
            commentError: `Sorry, but an error occurred. Please try again.`,
            emptyCommentError: `You need to write a response to submit a comment.`,
            errorMessage: `Comments failed to load.`,
            genericError: `Sorry, something went wrong.`,
            labelNoResponse: `Write a response to this article`,
            labelResponse: `See all responses to this article`,
            loading: `Loading`,
            postComment: `Post comment`,
            submittedComment: `Comment submitted. Thanks for contributing!`,
            writeComment: `Write a spectacular comment`,
            like: `Like`,
            unavailableLike: `You are not able to like this comment`,
            reportSubmitted: `Thank you for submitting a report about this comment. Your report will be added to a queue for our moderation team to review.`,
            emptyReportReason: `Please select a reason from the list for your report to be processed.`,
          },
      });
    });
  </script>
  </div>

</footer>      </div>


  <div class="sidebar">
  <div class="advert_container halfpage_container">
    <div class="advert mpu"
      data-dfp-id="DICEB_HP"
      data-dfp-sizes="300x600, 300x250, 300x1050"
      data-dfp-targeting="site=dicebreaker"
      id="DICEB_HP_1"
        data-dfp-collapse="true"
    ></div>
  </div>

      <div class="gn_sidebar"></div>
  </div>
  </div>

  <div id="content_below">
      <div class="page_content">
    <div class="advert_container low_leaderboard_container">
    <div class="lazyload low_leaderboard"
      data-dfp-id="DICEB_LB_2"
      data-dfp-sizes="300x250, 320x50, 728x90, 960x160, 960x250, 970x250, 1200x500"
      data-dfp-targeting="site=dicebreaker"
      id="DICEB_LB_2_AFTER_ARTICLE"
        data-dfp-collapse="true"
    ></div>
  </div>





      <section class="shelf" data-count="4" >
        <h2 class="section_title">More Videos</h2>



      <ul class="summary_list">
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="video"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.dicebreaker.com/topics/dall-e/video/ai-generated-board-game-art" class="link_overlay" title="Can you guess which board games these are from weird AI generated art?" ></a>




<div class="thumbnail">
  <img
    src="https://assets.dicebreaker.com/hqdefault-(2).jpg/BROK/thumbnail/283x159/format/jpg/quality/80/hqdefault-(2).jpg"
    srcset="https://assets.dicebreaker.com/hqdefault-(2).jpg/BROK/thumbnail/283x159/format/jpg/quality/80/hqdefault-(2).jpg 1x, https://assets.dicebreaker.com/hqdefault-(2).jpg/BROK/thumbnail/566x318/format/jpg/quality/80/hqdefault-(2).jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="AI generated art of board games"
width="283"height="159"  >
</div>
    <div class="details">


          <p class="title">
<a href="https://www.dicebreaker.com/topics/dall-e/video/ai-generated-board-game-art" >

                  Can you guess which board games these are from weird AI generated art?

</a>          </p>

            <p class="strapline">DALL-E the board game quiz show</p>

    </div>

    <div class="metadata">

    </div>

</article>          </li>
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="video"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.dicebreaker.com/topics/dicebreaker-podcast/video/podcast-episode-107" class="link_overlay" title="We get excited about the Magic: The Gathering 30th anniversary event and chat Arcs on the Dicebreaker Podcast" ></a>




<div class="thumbnail">
  <img
    src="https://assets.dicebreaker.com/dicebreaker-podcast-107.jpg/BROK/thumbnail/283x159/format/jpg/quality/80/dicebreaker-podcast-107.jpg"
    srcset="https://assets.dicebreaker.com/dicebreaker-podcast-107.jpg/BROK/thumbnail/283x159/format/jpg/quality/80/dicebreaker-podcast-107.jpg 1x, https://assets.dicebreaker.com/dicebreaker-podcast-107.jpg/BROK/thumbnail/566x318/format/jpg/quality/80/dicebreaker-podcast-107.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="The thumbnail for the Dicebreaker Podcast episode 107"
width="283"height="159"  >
</div>
    <div class="details">


          <p class="title">
<a href="https://www.dicebreaker.com/topics/dicebreaker-podcast/video/podcast-episode-107" >

                  We get excited about the Magic: The Gathering 30th anniversary event and chat Arcs on the Dicebreaker Podcast

</a>          </p>

            <p class="strapline">As well as dream-up our own tabletop summer camps.</p>

    </div>

    <div class="metadata">

    </div>

</article>          </li>
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="video"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.dicebreaker.com/topics/dicebreaker-podcast/video/podcast-episode-106" class="link_overlay" title="MCM Comic Con and UKGE reviewed in the latest episode of the Dicebreaker Podcast" ></a>




<div class="thumbnail">
  <img
    src="https://assets.dicebreaker.com/dicebreaker-podcast-106.jpg/BROK/thumbnail/283x159/format/jpg/quality/80/dicebreaker-podcast-106.jpg"
    srcset="https://assets.dicebreaker.com/dicebreaker-podcast-106.jpg/BROK/thumbnail/283x159/format/jpg/quality/80/dicebreaker-podcast-106.jpg 1x, https://assets.dicebreaker.com/dicebreaker-podcast-106.jpg/BROK/thumbnail/566x318/format/jpg/quality/80/dicebreaker-podcast-106.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="A thumbnail for the Dicebreaker Podcast episode 106."
width="283"height="159"  >
</div>
    <div class="details">


          <p class="title">
<a href="https://www.dicebreaker.com/topics/dicebreaker-podcast/video/podcast-episode-106" >

                  MCM Comic Con and UKGE reviewed in the latest episode of the Dicebreaker Podcast

</a>          </p>

            <p class="strapline">Alongside Warhammer 30K and more Crescent Moon.</p>

    </div>

    <div class="metadata">

    </div>

</article>          </li>
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="video"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.dicebreaker.com/topics/total-wipeout/video/dicebreaker-does-total-wipeout" class="link_overlay" title="Watch Dicebreaker fail at Total Wipeout in real life!" ></a>




<div class="thumbnail">
  <img
    src="https://assets.dicebreaker.com/hqdefault-(1).jpg/BROK/thumbnail/283x159/format/jpg/quality/80/hqdefault-(1).jpg"
    srcset="https://assets.dicebreaker.com/hqdefault-(1).jpg/BROK/thumbnail/283x159/format/jpg/quality/80/hqdefault-(1).jpg 1x, https://assets.dicebreaker.com/hqdefault-(1).jpg/BROK/thumbnail/566x318/format/jpg/quality/80/hqdefault-(1).jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="Image for Watch Dicebreaker fail at Total Wipeout in real life!"
width="283"height="159"  >
</div>
    <div class="details">


          <p class="title">
<a href="https://www.dicebreaker.com/topics/total-wipeout/video/dicebreaker-does-total-wipeout" >

                  Watch Dicebreaker fail at Total Wipeout in real life!

</a>          </p>

            <p class="strapline">Wheels and Maddie go head to head in Total Wipeout</p>

    </div>

    <div class="metadata">

    </div>

</article>          </li>
      </ul>

  </section>




      <section class="shelf" data-count="4" >
        <h2 class="section_title">Latest Articles</h2>



      <ul class="summary_list">
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="video"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.dicebreaker.com/topics/dall-e/video/ai-generated-board-game-art" class="link_overlay" title="Can you guess which board games these are from weird AI generated art?" ></a>




<div class="thumbnail">
  <img
    src="https://assets.dicebreaker.com/hqdefault-(2).jpg/BROK/thumbnail/283x159/format/jpg/quality/80/hqdefault-(2).jpg"
    srcset="https://assets.dicebreaker.com/hqdefault-(2).jpg/BROK/thumbnail/283x159/format/jpg/quality/80/hqdefault-(2).jpg 1x, https://assets.dicebreaker.com/hqdefault-(2).jpg/BROK/thumbnail/566x318/format/jpg/quality/80/hqdefault-(2).jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="AI generated art of board games"
width="283"height="159"  >
</div>
    <div class="details">


          <p class="title">
<a href="https://www.dicebreaker.com/topics/dall-e/video/ai-generated-board-game-art" >

                  Can you guess which board games these are from weird AI generated art?

</a>          </p>

            <p class="strapline">DALL-E the board game quiz show</p>

    </div>

    <div class="metadata">

    </div>

</article>          </li>
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="feature"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.dicebreaker.com/series/dungeons-and-dragons/feature/dnd-history-things-you-didnt-know" class="link_overlay" title="10 things you didn&#39;t know about the early history of D&amp;D" ></a>




<div class="thumbnail">
  <img
    src="https://assets.dicebreaker.com/dungeons-and-dragons-red-box-artwork.jpg/BROK/thumbnail/283x159/format/jpg/quality/80/dungeons-and-dragons-red-box-artwork.jpg"
    srcset="https://assets.dicebreaker.com/dungeons-and-dragons-red-box-artwork.jpg/BROK/thumbnail/283x159/format/jpg/quality/80/dungeons-and-dragons-red-box-artwork.jpg 1x, https://assets.dicebreaker.com/dungeons-and-dragons-red-box-artwork.jpg/BROK/thumbnail/566x318/format/jpg/quality/80/dungeons-and-dragons-red-box-artwork.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="Image for 10 things you didn&#39;t know about the early history of D&amp;D"
width="283"height="159"  >
</div>
    <div class="details">


          <p class="title">
<a href="https://www.dicebreaker.com/series/dungeons-and-dragons/feature/dnd-history-things-you-didnt-know" >      <span class="prefix">Feature:</span>



                  10 things you didn&#39;t know about the early history of D&amp;D

</a>          </p>

            <p class="strapline">From the RPG’s turbulent beginnings and the Satanic Panic to the fall of original publisher TSR.</p>

    </div>

    <div class="metadata">

    </div>

</article>          </li>
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="news"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.dicebreaker.com/games/root-game/news/root-clockwork-expansion-2" class="link_overlay" title="Root game expansion adds four new AI factions for co-op and solo play" ></a>




<div class="thumbnail">
  <img
    src="https://assets.dicebreaker.com/root-clockwork-expansion-2-cover.png/BROK/thumbnail/283x159/format/jpg/quality/80/root-clockwork-expansion-2-cover.png"
    srcset="https://assets.dicebreaker.com/root-clockwork-expansion-2-cover.png/BROK/thumbnail/283x159/format/jpg/quality/80/root-clockwork-expansion-2-cover.png 1x, https://assets.dicebreaker.com/root-clockwork-expansion-2-cover.png/BROK/thumbnail/566x318/format/jpg/quality/80/root-clockwork-expansion-2-cover.png 2x"
loading="lazy"    class="thumbnail_image"
    alt="An image of the cover of Root: The Clockwork Expansion 2"
width="283"height="159"  >
</div>
    <div class="details">


          <p class="title">
<a href="https://www.dicebreaker.com/games/root-game/news/root-clockwork-expansion-2" >

                  Root game expansion adds four new AI factions for co-op and solo play

</a>          </p>

            <p class="strapline">Mechanical moles and clockwork corvids.</p>

    </div>

    <div class="metadata">

    </div>

</article>          </li>
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="news"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.dicebreaker.com/games/tabriz/news/tabriz-game-announcement" class="link_overlay" title="New board game coming from designer behind Spiel des Jahres nominated Cascadia" ></a>




<div class="thumbnail">
  <img
    src="https://assets.dicebreaker.com/tabriz-cover.png/BROK/thumbnail/283x159/format/jpg/quality/80/tabriz-cover.png"
    srcset="https://assets.dicebreaker.com/tabriz-cover.png/BROK/thumbnail/283x159/format/jpg/quality/80/tabriz-cover.png 1x, https://assets.dicebreaker.com/tabriz-cover.png/BROK/thumbnail/566x318/format/jpg/quality/80/tabriz-cover.png 2x"
loading="lazy"    class="thumbnail_image"
    alt="The cover art for Tabriz."
width="283"height="159"  >
</div>
    <div class="details">


          <p class="title">
<a href="https://www.dicebreaker.com/games/tabriz/news/tabriz-game-announcement" >

                  New board game coming from designer behind Spiel des Jahres nominated Cascadia

</a>          </p>

            <p class="strapline">From the Pacific Northwest to Persia.</p>

    </div>

    <div class="metadata">

    </div>

</article>          </li>
      </ul>

  </section>




  <a
    href="https://store.reedpop.com/collections/Dicebreaker"
    class="merch_component "
    target="_blank"
    rel="noopener"
    title="Critical hits, perfect fits"
  >
    <div class="details">
        <img
          src="https://assets.dicebreaker.com/0275_dicebreaker-logo%402x.png"
          alt="Dicebreaker logo"
          loading="lazy"
        />
      <p class="title">Critical hits, perfect fits</p>
      <p class="strapline">Buy Dicebreaker T-shirts, hoodies and more</p>
      <button class="button">Explore our store</button>
    </div>
    <div class="asset">
      <img
        src="https://assets.dicebreaker.com/0422_dicebreaker-merch.png"
        alt="Dicebreaker Merch"
        loading="lazy"
      />
    </div>
  </a>

  <script>
    buttons = document.querySelectorAll('.merch_component');
    for (i = 0; i < buttons.length; i++) {
      buttons[i].addEventListener('click', function(e) {
        gtag('event', 'click', {
          'event_category': 'Store Component',
          'event_label': window.location.href
        });
      });
    }
  </script>
      </div>
  </div>
            </div>

        </main>

        <footer class="app_footer">
  <div class="nav_wrapper">
      <div class="about">


<a
  href="/"
  class="logo"
  
>
    <img src="https://assets.dicebreaker.com/0275_dicebreaker-logo.svg" alt="Dicebreaker logo" loading="eager">
</a>
  <p class="tagline">Board games. For everyone.</p>

  <form class="search_box" action="/search">
    <input type="text" name="q" aria-label="Search" placeholder="Search">
  </form>

  <p>Copyright © 2022 Gamer Network Limited, a ReedPop company.</p>
  <p>All rights reserved. No part of this site or its content may be reproduced without the permission of the copyright holder.</p>


  <nav class="social_follow">
    <ul class="social_list">
          <li>
            <a
              href="https://www.facebook.com/joindicebreaker"
              class="social_icon"
              data-type="facebook"
              data-action="follow"
                rel="noopener"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="facebook-f"
      data-type="brands"
        title="Check us out on Facebook"
    ></span>


            </a>
          </li>
          <li>
            <a
              href="https://twitter.com/joindicebreaker"
              class="social_icon"
              data-type="twitter"
              data-action="follow"
                rel="noopener"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="twitter"
      data-type="brands"
        title="Check us out on Twitter"
    ></span>


            </a>
          </li>
          <li>
            <a
              href="https://www.instagram.com/dicebreaker"
              class="social_icon"
              data-type="instagram"
              data-action="follow"
                rel="noopener"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="instagram"
      data-type="brands"
        title="Check us out on Instagram"
    ></span>


            </a>
          </li>
          <li>
            <a
              href="https://www.youtube.com/dicebreaker"
              class="social_icon"
              data-type="youtube"
              data-action="follow"
                rel="noopener"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="youtube"
      data-type="brands"
        title="Check us out on YouTube"
    ></span>


            </a>
          </li>
          <li>
            <a
              href="/feed"
              class="social_icon"
              data-type="rss"
              data-action="follow"
                rel="alternate noopener"
                type="application/rss+xml"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="rss"
      data-type="solid"
        title="Check out our RSS feed"
    ></span>


            </a>
          </li>
    </ul>
  </nav>
      </div>



  <nav class="nav_primary">
            <span class="label">Explore</span>


        <ul>
                  <li>
                    <a
                      href="/archive/news"
                      data-active="false"
                      
                    >
                        News
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/review"
                      data-active="false"
                      
                    >
                        Reviews
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/features"
                      data-active="false"
                      
                    >
                        Features
                    </a>
                  </li>
                  <li>
                    <a
                      href="/videos"
                      data-active="false"
                      
                    >
                        Videos
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/deal"
                      data-active="false"
                      
                    >
                        Deals
                    </a>
                  </li>
                  <li>
                    <a
                      href="/best-games"
                      data-active="false"
                      
                    >
                        Best Games
                    </a>
                  </li>
                  <li>
                    <a
                      href="/how-to-play"
                      data-active="false"
                      
                    >
                        How to Play
                    </a>
                  </li>
                  <li>
                    <a
                      href="/categories/board-game"
                      data-active="false"
                      
                    >
                        Board Games
                    </a>
                  </li>
                  <li>
                    <a
                      href="/categories/roleplaying-game"
                      data-active="false"
                      
                    >
                        Roleplaying
                    </a>
                  </li>
                  <li>
                    <a
                      href="/events"
                      data-active="false"
                      
                    >
                        Events
                    </a>
                  </li>
        </ul>
  </nav>



  <nav class="nav_secondary">
            <span class="label">Popular Now</span>


        <ul>
                  <li>
                    <a
                      href="/games/dungeons-and-dragons-5e"
                      data-active="false"
                      
                    >
                        Dungeons &amp; Dragons 5E
                    </a>
                  </li>
                  <li>
                    <a
                      href="/games/magic-the-gathering-game"
                      data-active="false"
                      
                    >
                        Magic: The Gathering
                    </a>
                  </li>
                  <li>
                    <a
                      href="/topics/kickstarter"
                      data-active="false"
                      
                    >
                        Kickstarter
                    </a>
                  </li>
                  <li>
                    <a
                      href="/topics/dicebreaker-podcast"
                      data-active="false"
                      
                    >
                        Dicebreaker Podcast
                    </a>
                  </li>
                  <li>
                    <a
                      href="/games"
                      data-active="false"
                      
                    >
                        Latest Games
                    </a>
                  </li>
        </ul>
  </nav>



  <nav class="nav_helpful">
            <span class="label">Helpful Links</span>


        <ul>
                    <li>
                    <a
                      href="/about"
                      data-active="false"
                      
                    >
                        About Us
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/2022/06"
                      data-active="false"
                      
                    >
                        Archive
                    </a>
                  </li>
                  <li>
                    <a
                      href="/authors"
                      data-active="false"
                      
                    >
                        Authors
                    </a>
                  </li>
                  <li>
                    <a
                      href="/code-of-conduct"
                      data-active="false"
                      
                    >
                        Code of Conduct
                    </a>
                  </li>
                  <li>
                    <a
                      href="mailto:contact@dicebreaker.com"
                      data-active="false"
                      
                    >
                        Contact Us
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://privacy.rxglobal.com/en-gb/cookie-policy.html"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Cookie Policy
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.reedpop.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Corporate Site
                    </a>
                  </li>
                  <li>
                    <a
                      href="/editorial-policy"
                      data-active="false"
                      
                    >
                        Editorial Policy
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://privacy.rxglobal.com/en-gb/ccpa.html"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Notice to California Residents
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://privacy.rxglobal.com/en-gb.html"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Privacy Policy
                    </a>
                  </li>
                  <li>
                    <a
                      href="/review-policy"
                      data-active="false"
                      
                    >
                        Review Policy
                    </a>
                  </li>
                  <li>
                    <a
                      href="/terms-and-conditions"
                      data-active="false"
                      
                    >
                        Terms &amp; Conditions
                    </a>
                  </li>


      <li>
        <button class="optanon-show-settings">
Cookie Settings        </button>
      </li>
        </ul>
  </nav>



  <nav class="nav_sites">
            <span class="label">ReedPop</span>


        <ul>
                  <li>
                    <a
                      href="https://www.cosplaycentral.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Cosplay Central
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.eurogamer.net"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Eurogamer
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.gamesindustry.biz"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        GamesIndustry.biz
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.jelly.deals"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Jelly Deals
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.metabomb.net"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Metabomb
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.nintendolife.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Nintendo Life
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.thepopverse.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Popverse
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.pushsquare.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Push Square
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.rockpapershotgun.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Rock Paper Shotgun
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.thehaul.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        The Haul
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.usgamer.net"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        USgamer
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.vg247.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        VG247
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.videogameschronicle.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        VGC
                    </a>
                  </li>
        </ul>
  </nav>
  </div>
        </footer>
    </div>
  </body>
</html>